Norgate Data Products Support Corporate
General Support
- Downloads
- How to Download
- Installation
- Downloading / Installation FAQ
- Data File Corruption
- Antivirus Programs
- Submit Problem Report
- Premium Data Converter
- Smart Charts Copier
- The MetaStock Data Format
- Virtual Environments
Sales Support
- Order Form
- Refunds Policy
- My Account
- Forgot Password
- Price
- Free Trial
- History Only Purchases
- Installing on a Second Machine
- How to Upgrade an ASX Subscription
- Privacy Policy
- Licence Agreement
Premium Data/Stock Market Support
- Premium Data FAQ
- Exchange Traded Funds
- ASX FAQ
DataTools/Futures Support
- DataTools FAQ
- DataTools Service Information
- Understanding Futures Data
- Futures Coverage Notes
- Futures Database Notes
- Futures Contract Detail (Spreadsheet)
- Futures - Continuous Contracts
Forex Support
- Premium Forex FAQ
- Premium Forex Service Information
Charting Programs & Our Data
- Switching To Us From Another Vendor
- Advanced GET FAQ
- AmiBroker FAQ
- Dynamic Trader FAQ
- FCharts FAQ
- Fibotrader FAQ
- Gannalyst FAQ
- Guppytraders Essentials FAQ
- HotTrader FAQ
- Market Analyst FAQ
> MetaStock™ FAQ
- MTPredictor FAQ
- Omnitrader FAQ
- Stock Neuromaster FAQ
- Trading Blox FAQ
- TradeGuider FAQ
- TradeStation FAQ
Market Resources
- Alternative Market Glossary
- Links to Other Sites
Notices
- dataHQ Service Notice

Using Our Data With MetaStock™

Overview (for MS versions up to v.11)
Illustrations
FAQ
Known Issues
Overview (for MS version XV)
Guides to using Local Data in MetaStock™ XV

Please Note! - the information on this page is split into 2 sections. The first section applies to MetaStock™ versions up to version 11. MetaStock™ versions 12, 13 and 14 could only access data provided through Reuters Datalink™. There is a separate section for MetaStock™ version XV at the bottom of the page.

Overview (for MS versions up to v.11)

In order to read our data with MetaStock™, there is no need to import it "into" MetaStock™ or configure The Downloader™ in any way. All you need to do is go File > Open, select “Local Data” and then navigate to the location on your machine where our data is installed. Once you open one of our data files with MetaStock™, it will remember the path you followed to get there and then offer you data from that location next time around. This makes it appear as if the data is now "in" MetaStock™.

Illustrations

Click on a link below to see illustrations of how to open our data with MetaStock™.

Stocks
Forex
Futures

FAQ

When I start MetaStock™, it gives me the error message "The online vendor account is not configured properly or does not support this feature". How do I fix this?
This probably means that you’ve tried to enter your log-in details at Application Properties > Reuters Datalink. To remove these details, start up MetaStock™ and, after it presents the error message, click "Work Offline". Then click Tools > Options and select the “Reuters Datalink” tab. Then delete the entries for User ID and Password. Finally, click “O.K.” and shut down MetaStock™.

When I go to open a file, I can't see any security symbols or names – just files F1.dat, F2.dat etc. If I try to open one of these, I get “Not a valid MetaStock file for Windows”. What am I doing wrong?
In the File > Open dialog, you need to select Files of Type = Smart Charts (at the bottom).

Click here for an illustration

When I go to open a file, I can't see any security symbols or names, even though I have Files of type = Smart Charts selected. How can I fix this?
In the File > Open dialog, you need to make sure that the Symbol box is empty.

Click here for more information and an illustration

Why can I only see two years of data?
By default, MetaStock™ only shows 400 data points (somewhat under two years). To see more data in a chart, you will need to adjust the program’s Load Options. A setting of 5,000 will typically show about 20 years of daily data.

Click here for an illustration

I hate having to add all the individual A-Z sub-folders for an Exploration. Is there an easier way?
For most of the stock exchanges we cover, we offer the ability to eliminate the A-Z sub-folder structure. Open Premium Data (our Stocks updating product), click the Configuration Tab and then the “Database Structure” button at bottom right. Follow the instructions there to eliminate (or restore) A-Z sub-folders.

Please note: if A-Z sub-folders are eliminated, some of your data folders may contain over 2,000 securities. You will need to be using MetaStock™ v.8 (or higher) in order to be able to read that many securities in a single folder.

I am accessing the US historical data and looking at the Open Interest field to obtain the unadjusted close. However, the values there are only shown in whole numbers. How can I see the actual unadjusted close in detail?
Many charting programs (including MetaStock™) pre-suppose that Open Interest will be a whole number. To "trick" MetaStock™ into revealing the full value of the unadjusted closes, create a new indicator in the Indicator Builder called “OriginalClose” and enter the formula as OI + 0. Then use this indicator to plot the unadjusted close.

I want to see “date-padded” data - can I do this in MetaStock™?
It is possible to emulate date-padded data using Metastock. Dates on which no trades were recorded will appear as blank gaps in the chart.

  1. Open up a chart of any stock.
  2. Right-click on a blank area of the chart and select “Chart Window Properties”.
  3. Make sure that “Show inner window title bars” and “Show inner window splitter bars” are enabled. Then click OK.
  4. Open up a chart of an appropriate index to use a date reference. For instance, use the S&P 500 as a date reference for any U.S. stock.
  5. Click Window > Tile. You should now see one chart on top of the other.
  6. Left-click on the price display in the index chart to select it and then drag the prices to the bottom of the stock chart around where the dates are shown. You should now see the index chart as an “inner window” at the bottom of the stock chart.
  7. Close down the original index chart that you opened in step 4.
  8. Right-click on a blank area of the stock chart and select “Chart Window Properties”.
  9. Untick “Show inner window title bars” and click OK.
  10. Drag the splitter bar just above the index chart downwards as far as it will go. This will "resize" your index price display so as to ultimately hide it, leaving only the dates.
  11. Click File > Save As. Select “Template” as the Save As type and call the template something like "Padded".
Any time you want another chart to show padded data, simply right-click on the chart in question, select Apply Template and apply the “Padded” template.

Where can I get help on using MetaStock™?
For a basic tutorial on the MetaStock™ formula language, see the Metastock Formula Primer. For a fantastic MetaStock™ newsletter see MetaStock Tips and Tools Newsletter. For a wide range of indicators and also custom programming services see Jose Silva's Metastock Tools site. There are a few Metastock™ support forums available on the Internet too - Equis Metastock Forum, Yahoo Finance Equis Metastock Group, The Chartist MetaStock Forum (Reefcap) and Stock Meeting Place Metastock Forum.

Known Issues

Limitation on number of files per data folder
Very early versions of MetaStock™ (before v6.5) could only read up to 255 files per folder. From v6.5, the program was able to read up 2,000 files and from v8 it could read up to 6,000 files.

Absolute file references
MetaStock™ allows you to go beyond “Smart Charts” and create what it calls “Charts” and “Layouts”. You can save many different versions of the same Chart under different names and you can create a Layout of charts and then save the Layout with a distinctive name. Unfortunately, these objects rely on absolute file references. Let’s say that your ASX data is installed under c:\Trading Data\Stocks\ASX and you create a series of Layouts from your ASX database. MetaStock™ “remembers” the exact location of each underlying data file in each Layout. Now let’s say that you wish to move your ASX database from your c: drive to your d: drive because your c: drive is full. The MetaStock™ Layouts that you have created will no longer work, because they are based on data files that used to be located elsewhere.

Accidental folder drag
Sometimes, during the File > Open process in MetaStock™, a double-click on a folder name can be handled incorrectly, the result being a click-drag-click action. This can cause one sub-folder to be dragged inside another. Typically, the affected folder will be an alphabetical sub-folder such as the “B” folder, which is dragged inside the ”A” or “C” folder. The “B” folder will continue to update successfully, but eventually another version of the folder will be created in the correct position (for instance, when a new stock starting with “B” is added the database).

Data Files Left Open
Corruption can occur in the following circumstances -

  1. if your machine loses power or locks up during an update.
  2. if MetaStock™ is closed abnormally with data files still open.
If you are unable to access data files in a particular data sub-folder, check the folder using Windows to see if the following files are present -

~MSFL.INX
~MSFL.LCK
~MSFL.SEC
~MSFL.USR
MASTER.TMP
EMASTER.TMP
XMASTER.TMP

If any or all of these files are present, delete them, taking care not to delete any other files.

The Equis/MetaStock Knowledge Base has advice on this issue here.

MetaStock™ Favourites
File corruption may also be associated with the use of the "Favourites" feature in MetaStock™. It is known that since MetaStock™ version 8, the file that stores information about Favourites (Favourites.dta) may become corrupted, particularly when the results of Explorations are added to it. If there is a resulting problem with trying to open a security from Favourites, the data folder that holds that security may also become corrupted (it appears as if the folder has been emptied).

If you are using the Favourites feature in MetaStock™, and finding that data sub-folders are being repeatedly emptied, try deleting the file Favourites.dta (please be aware that you will lose all of your current Favourites). A new Favorites.dta will be created when you start adding securities to the Favourites list again. Once you have a fresh Favourites.dta in place, we recommend changing the database structure to remove alphabetical sub-folders. Please see our FAQ on how to do this here.

Overview (for MS version XV)

MetaStock™ version XV was released in November 2016, with the ability to read "Local Data" (from independent data vendors) re-introduced to the application.

However, the procedure for reading Local Data is different to that which earlier versions employed.

With MetaStock™ version 11 (and earlier versions) a user simply went File > Open to have direct access to the contents of a local data folder.
With MetaStock™ version XV, the user is required to import the contents of a local data folder as a list of symbols.

There are two issues with having to import lists of symbols -

  1. If a local data folder is divided into A-Z sub-folders, then each sub-folder needs to be imported separately. Users of our Premium Data updating software (for stocks) can get around this issue by electing to consolidate the data folders (eliminate the A-Z sub-folder structure). See our FAQ - I don't want alphabetical sub-folders in my stocks database. Can I get rid of them?
  2. The import procedure needs to be repeated in order to keep up-to-date with changes to the folder contents. For instance, if a stock undergoes a symbol change, or a new stock is added to the folder, the changes would not be reflected in the list of previously imported symbols.

This issue is particularly relevant to our update services for ASX and US Stocks, where symbols are added or changed frequently. It is less relevant to Futures, where new symbols are added as "back-month" contracts. It is not really relevant to Forex at all, where the symbols are static.

We have also found another issue with MetaStock™ XV that is relevant to stock market subscribers. The "World Indices" folder includes the history of the Dow Jones Industrial Average back to 1896. Our testing has discovered that MetaStock™ XV appears to have an issue handling dates in the 19th century. It won't import the contents of the "World Indices" folder at all unless the history of the Dow is first reduced. This can be done with a tool found under the "Maintenance" tab of our Premium Data updating application, which reduces the history to a start year of 1920.

Guides to using Local Data in MetaStock™ XV

https://www.youtube.com/watch?v=6tzrQOGAM-0
https://www.youtube.com/watch?v=DipHNZ-0ZBQ





















































MetaStock is a registered trademark of Equis International, Inc.